Vers une évolution du Thymio 2 ?


#21

“le bluetooth permettra d’utiliser les capteurs, la caméra et la puissance de calcul du téléphone.”

Tout à fait, il y a peut-être un plan pour ça chez nous… à suivre ;o)

“Je compte bien mettre quelques photos sur votre site.”

Ce serait avec grand plaisir ! Si vous avez le moindre soucis à le faire, n’hésitez pas à nous contacter soit ici, soit sur le forum Thymio là: https://aseba.wikidot.com/forum:start


#22

Bonjour,
peut-être une question dont la réponse intéressera d’autre utilisateur de THYMIO filaire.
En effet, je n’arrive pas à trouver l’astuce de branchement et débranchement de Thymio entre 2 modification de programme ASEBA VPL.
Que faut-il faire ( ou ne pas faire ) pour éviter le crach d’ASEBA et la non reconnaissance du plug Thymio et donc ne pas avoir à tout relancer ?
Robotiquement
Sébastien


#23

1/ Faire le programme.
2/ Le sauvegarder au cas où en local.
3/ Le lancer.
4/ Débrancher le thymio : il exécute le programme tant qu’on ne l’éteint pas et, du côté ordi, VPL râle parce que son robot préféré n’est plus branché et ferme son interface (mais est toujours actif).
5/ Ne toucher à rien (ni à l’ordi, ni au robot toujours allumé), seulement rebrancher le robot, quelques secondes pour que VPL le reconnaisse comme sien et il ré-ouvre son interface.
On croit que VPL est planté mais pas du tout, il se met en veille si le robot n’est pas branché, c’est tout.
Ceci étant, ce n’est clairement pas pratique et va être corrigé (@cbarraud, @smagnenat, vous confirmez ?).


#24

Le déroulement est juste en effet Didier, il faut juste, après avoir débranché le robot, le rebrancher.

J’ajouterai juste une chose. On peut voir cette fenêtre s’ouvrir:

Il ne faut absolument pas la fermer ou cliquer sur “Stop trying”, sinon il faudra en effet relancer Aseba. Il suffit juste de rebrancher le robot.

Il peut arriver, notamment sous Windows, qu’Aseba ne remarque pas que Thymio a été débranché, et du coup, lorsqu’on le rebranche, il ne le remarque pas non plus. C’est au moment où on essayera de changer le programme ou de le lancer dans Thymio que ça va coincer. Le mieux, c’est, si cette fenêtre n’apparaît pas au moment du débranchement de Thymio, de cliquer sur “play”, ça va faire comprendre à Windows que Thymio est débranché et la fenêtre de reconnection devrait s’afficher. Alors, plus qu’à brancher Thymio.

Et oui, c’est quelque chose qui n’arrivera plus dans les prochaines version :wink:

À bientôt !


#25

Donc voici l’algorithme de (re)connection Thymio à ASEBA VPL :

Lancer programme;
Débrancher Thymio;
SI “stop trying” apparaît ALORS ne pas fermer
SINON cliquer "Play"
Rebrancher Thymio
Attendre
Recommencer

C’est bon ?
@cbarraud @droy


#26

Exactement !

:slightly_smiling:


#27

Bonjour,
Sur mac, quand je lance asebadummynode le terminal réponds :
"dyld: Library not loaded: @executable_path/…/Frameworks/libdashel.1.dylib
Referenced from: /Documents/robotique/thymio/Asebascratch/bin/asebadummynode
Reason: image not found
Trace/BPT trap: 5 "
J’ai lancé la dylib manuellement, mais même réponse …
Que faire ?
Merci d’avance